Open Linux Forums
Like Ubuntu forums, except with beer.
Moderator
Joined: Oct 04 2017
Posts: 1253

I've noticed now that at the top of login screen in testing that the choices to restart etc isn't there any longer. Only the font, and to change to openbox or whatever you have listed as an additional. I checked around but don't see the choices of restart anywhere there anymore.

Administrator
avatar
Joined: Jan 06 2018
Posts: 1697

There's probably a keyboard shortcut. Likely one of the F keys. You could also try CTRL+ALT+Delete

Moderator
Joined: Oct 04 2017
Posts: 1253

Will try that next time booting up. Right now in stable messing around. No, not going to fuck it up. That's what testing is for. I learned my lesson from the old forum. 🚶 😉

Administrator
avatar
Joined: Jan 06 2018
Posts: 1697

Sure.

Moderator
Joined: Oct 04 2017
Posts: 1253

Wellll, I did learn not to turn around and talk to someone and remove finger from mouse when experimenting with transparency or to get up and get a cup of coffee when upgrading to a new version and not catch what's going on with it. That has a tendency to kinda screw things up at times when you do either one of those two for some screwed up reason or another.

Member
Joined: Oct 04 2017
Posts: 361

What DM are you using?

Lightdm?

Moderator
Joined: Oct 04 2017
Posts: 1253

lightdm

Member
Joined: Oct 04 2017
Posts: 361

Georgiaboy wrote:

lightdm
I couldn't check on that before as I was pretty sure you were not using lxdm which I am using on the external 64OB install and that install is OB only.

But I am now on the internal Stoned Lizard where I use lightdm and have both Xfce and OB installed. I even logged out to double check that the option for what DE you log into is still there.

It is there on this install and appears to work. didn't change over to OB but it has always worked in the past.

There should be 3 options on the top panel of lightdm and the one 3rd from the right should give you that option.

I also checked in
/etc/lightdm/lightdm.conf
/etc/lightdm/lightdm-gtk-greeter.conf
/etc/lightdm/users.conf

and see nothing in either of them that should need changed to have that option. Mine are all dead default settings except for
/etc/lightdm/lightdm-gtk-greeter.conf

on which I have modified the background to use a different image.

I think that while those files are all pretty long (except user.conf) that there are only about 3 lines each not commented out.

I would check that panel again to make sure you are correct in your description of the problem and if so I would take these steps in trying to correct the problem.

# dpkg-reconfigure lightdm

Reboot and check. If that hasn't fixed it then

# apt-get purge lightdm

then

# apt-get install lightdm

You could try

# apt-get install --reinstall lightdm

instead of the first (dpkg) option but the dpkg command has had a better history with me in correcting slightly screwed applications.

As long as you lightdm package isn't in and of itself somehow screwed all it needs is the install scripts rerun and dpkg will do that. If the package is screwed the install -- reinstall will end up pretty much just running like a package upgrade and that may not change any files at all whereas if you purge the package before reinstalling it all the system config files will be removed and you get a new, clean start.

If you have changed anything in the "greeter" you may want to save that file someplace to see what you did. I wouldn't use that file as a replacement because there may be something in it causing the problem. But you would have the relevant line(s) you modified as a guide to what to do with the new one. If this is the case make sure you back up the original file before modification.


Edit: code tags... <sigh>

Moderator
Joined: Oct 04 2017
Posts: 1253

Tried all and still same.

Member
Joined: Oct 04 2017
Posts: 361

Georgiaboy wrote:

Tried all and still same.

That sucks.

Try a different DM. Gdm is about the same as LightDM. I don't know what Mate uses, probably LightDM, but there could be something like MDM.

Could be that the problem is with 32bit systems or 32bit version of lightdm not working on 64bit systems properly.

Seems to work fine on both my Lizards (Testing and Sid) under Xfce with OB installed too.

I have a bit of trouble trusting Lightdm due to being a Launchpad project.

Am using lxdm on here (64OB) and the next install is going to go with xdm. Lxdm from Debian anyway is pretty much set up to go with lxde installs and that makes sense but it, by default doesn't show a DE option box. Easily fixed in the config file (change the 'bottom panel' line to end with =1 instead of =0 - really tough).

Have used xdm and it is really good but I don't think I ever used it on a multi DE system and don't remember much about it. Don't really like the layout of the login screen. This is a big concern as I have to look at it for several seconds. Bugger is old reliable and able to handle remote logins by it self in a secure manner. Don't think that looks is a major concern and I need to revisit it.

One of those may have better luck with 32bit boxen than lightdm.