Open Linux Forums
Like Ubuntu forums, except with beer.
Administrator
avatar
Joined: Jan 06 2018
Posts: 1697

Since I'm running my entire OS from a damned jump drive, I need every scrap of space I can find. I can't afford a 5% system reserve in my /home partition. For me, that's 1 GB out 20. I wanna 'ave it BACK! (Said the temper tantruming warfacegod. Gimme it. 'T's Mine! My Precious!) Right! Moving along.. eehheemmm!

sudo tune2fs -m 0 /dev/sdb3

Returns this:

tune2fs 1.42.12 (29-Aug-2014)
tune2fs: Filesystem has unsupported read-only feature(s) while trying to open /dev/sdb3
Couldn't find valid filesystem superblock.

I've already tried using a higher percentage. Same result. Also, setting the reserve to 0% on sdb2 (my root partition) worked just fine. (Normally wouldn't do that but I needed to test tunefs.)

Administrator
avatar
Joined: Oct 04 2017
Posts: 395

So, which distro are you running from this stick?

Administrator
avatar
Joined: Jan 06 2018
Posts: 1697

Mint LMDE with a bunch of garbage ripped out. I found numerous references to this same and similar thing all related to Debian and OS's based on it. I remember running into this or something nearly identical 5 years ago. I just don't remember how I dealt with it. I think it was a minor change in the command. Like a force flag or the like. I'm so rusty at this stuff that I don't trust my instincts anymore.

Administrator
avatar
Joined: Oct 04 2017
Posts: 395

Then move this thread to the Debian section...

Administrator
avatar
Joined: Oct 04 2017
Posts: 395

Ok... so had to do it myself again... le sigh

Administrator
avatar
Joined: Jan 06 2018
Posts: 1697

What would I ever do without you? Oh, use the smileys! 😛

Moderator
Joined: Oct 04 2017
Posts: 1253

How did you get that smiley?

Administrator
avatar
Joined: Jan 06 2018
Posts: 1697

Start you're own help thread. 😝