Open Linux Forums
Like Ubuntu forums, except with beer.
Moderator
avatar
Joined: Oct 04 2017
Posts: 235

so I wanted to play a DVD I own which happens to be "restricted", copy-righted or whatever it's called.

so I searched and found this: https://askubuntu.com/questions/1052993/how-to-install-libdvdcss-so-2-library-to-ubuntu-18-04#
namely:

sudo apt install libdvdnav4 libdvdread4 gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly libdvd-pkg
sudo dpkg-reconfigure libdvd-pkg 
sudo apt install ubuntu-restricted-extras

I wrote the commands exactly as written in that page but one seemed to be going on for a long time and I cleared the terminal (maybe that was wrong. derp)

anyway, I got this message:

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable

I've got Ubuntu 18.04 right now. I seem to recall that an earlier version let me play that DVD with no problem. Probably because those libs already came with the distro or because somehow I installed the libs, who remembers.

what can I do to fix this dopey problem? Should I reboot and try again?

Member
Joined: Nov 19 2017
Posts: 266

I'd try rebooting, running sudo apt-get update then re-running the previous command, but changing the apt to apt-get.

Administrator
Joined: Nov 08 2017
Posts: 1022

Hi Cecilia.
First up: I'm out of practice, so I'm guessing a bit. Anyway...

What do you mean "cleared the terminal"? As I understand it, once a process has been started, it runs until it is finished, or it crashes. Clearing the text out of the terminal shouldn't stop it, I believe.

The message means that the system believes that the config.dat file is being changed by some process, but I think you know that. I would have a look with the system monitor thing, (my system is in German, and it is called "system├╝berwachung") and see if I could see what process that might be. Sometimes, if a process has hung up, one can stop it there.

Re-boot is probably a good idea, either as a last resort, or a first, depending on how patient one is feeling.

I've just had a look on here: I've got libdvdcsss2 installed, (Ubuntu 18.04.03 LTS). I honestly can't remember if I installed that manually. I think so, but I'm pretty sure it was before the update to this Ubuntu version (using the automatic update...). It may have even been a couple of updates back.

Have you got synaptic package manager installed? If so, you could search libdvdcss in there, and let it install anything it reckons it needs for that. I tend to try that first of all if the system says it is missing something. My experience of synaptic is that it seems to pull in all the dependencies it needs, and keep up with the "housework", so that the system (dpkg etc.) knows what is installed and is on top of things.

All a bit vague, I know. Hope it helps.

Moderator
avatar
Joined: Oct 04 2017
Posts: 235

well, I shut off the laptop last night (of course) and this morning the issues were still there so after coming here and reading your replies I figured I would try to just reinstall again.

I think yesterday I just messed up while it was trying to install the fonts. I forget that you can use the "tab" key to help answer "yes" when they want you to accept their legal documents.

anyway, I figured that out (finally) and the installation seemed to have worked ok. Now I have to insert the DVD to see if it worked but I have to shower first and make sure I have shopping done for dinner. So, I'll let you guys know if it worked out later

thanks

you guys ROCK!